Back to overview
Degraded
Degraded services for Clover users
Nov 09 at 11:35pm UTC
Affected services
Core Services
Resolved
Nov 10 at 02:44am UTC
Clover functionality has been restored. All services are working now as expected.
Thank you for your ongoing patience!
Affected services
Core Services
Created
Nov 09 at 11:35pm UTC
Clients with Clover devices are reporting issues where they are unable to process payments. The device goes to a black screen rather than processing.
Clover has identified the issue and is actively working to resolve it.
https://status.clover.com/incidents/x6lk769h9cbc
At this time users can still use the clover sales app to process payments.
Affected services
Core Services