Back to overview
Degraded

Degraded Services Softpoint Services

Apr 02 at 08:30am UTC
Affected services
Core Services

Resolved
Apr 02 at 10:55am UTC

RESOLVED - The Service disruption was caused by unscheduled maintenance at our server hosting company. This incident has been resolved.

Created
Apr 02 at 08:30am UTC

INVESTIGATING - We are experiencing a service disruption with Softpoint Servers that would cause problems with payments and ordering features. We will provide updates as they become available.